[CentOS] floppy drives

Tue Apr 9 00:50:10 UTC 2013
mark <m.roth at 5-cent.us>

On 04/08/13 12:55, Louis Lagendijk wrote:
> On Mon, 2013-04-08 at 12:21 -0400, m.roth at 5-cent.us wrote:
>> That I don't know, and was trying to think of a way to test it. As I noted
>> in another post, the 5.25" light seems to stay on, and I *think* that was
>> the one I had disconnected before. I also think I mentioned that after
>> bringing it down, connecting, and rebooting, I looked at the BIOS, and it
>> told me it *only* saw the 3.5" drive.
>> <snip>
> That is why I thought of the cable/drive issue. Please keep in mind that
> the bios versions I recall did not detect a drive unless it was told
> that there was one (you had to even specify the type/ format of the
> drive)
>>> Any chance that

You gents nailed it. I brought my machine down again, and set the BIOS 
to see the 1.2M as a, and the 1.44 as b: while it was down, before I did 
that, I looked... I'm sure the cable was on, but it's really hard to see 
the open side of the case still covers about a third of the board, and 
with all the cables.... Pulling out my trusty minimag, and moving 
cables... and it was upside down. I don't know how it got on that way, 
certainly I wouldn't have forced it, but flipped it over, and played 
with the BIOS... the 3.5" drive still doesn't work... but the 1.2M 
floppy, as b: *does* work - light goes on only when I try to read it, 
and not otherwise.

Now I don't know if I have a drive cleaner, since I can't believe none 
of the first 10 or so disks I tried to look at was readable.

But I'm over the first hump. Now I'm playing with /dev/fd1 and 
/dev/floppy-fd1 (and why is it trying to read a superblock when I try to 
mount it, when I've said -t msdos? Oh, well, onward in the fight.)