[CentOS] Problem building powerdns from EPEL

Tue Apr 9 21:47:36 UTC 2013
Morten Stevens <mstevens at imt-systems.com>

On 09.04.2013 22:48, Nikolaos Milas wrote:
> Hi,
> I just tried to build using
> http://dl.fedoraproject.org/pub/epel/6/SRPMS/pdns-3.1-2.el6.src.rpm on
> CentOS 6.4 final (kernel: 2.6.32-358.2.1.el6.x86_64), but it failed when
> looking for ldap libs:
> Note: I did not change anything in the original spec file.
>      ...
>      + ./configure --build=x86_64-redhat-linux-gnu
>      --host=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux-gnu
>      --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
>      --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
>      --includedir=/usr/include --libdir=/usr/lib64
>      --libexecdir=/usr/libexec --localstatedir=/var
>      --sharedstatedir=/var/lib --mandir=/usr/share/man
>      --infodir=/usr/share/info --sysconfdir=/etc/pdns
>      --libdir=/usr/lib64/pdns --disable-static --with-modules= --with-lua
>      '--with-dynmodules= gmysql gpgsql pipe geo ldap gsqlite3'
>      --enable-cryptopp
>      ...
>      checking for ldap_set_option in -lldap_r... no
>      checking for ldap_set_option in -lldap... no
>      configure: error: ldap library (libldap) not found


I'm the powerdns maintainer for Fedora and Fedora EPEL. There's no 
problem then rebuilding pdns-3.1-2.el6.src.rpm on CentOS 6.4 with mock/koji.

Please check:

checking for ldap_set_option in -lldap_r... yes
checking for ldap_initialize in -lldap_r... yes

The same result on my local CentOS 6.4 build server running mock -r 
epel-6-x86_64 --rebuild pdns-3.1-2.el6.src.rpm.

As you can see there is no problem with the ldap library for 
CentOS/RHEL. That's probably a problem on your build server.

Best regards,