[CentOS] Formatting a USB Drive

Thu Apr 11 10:20:45 UTC 2013
John Doe <jdmls at yahoo.com>

From: Jason T. Slack-Moehrle <slackmoehrle at gmail.com>
> So I run:
> # parted
> GNU Parted 2.1
> Using /dev/sda
> Welcome to GNU Parted! Type 'help' to view a list of commands.
> (parted) select /dev/sdg
> Using /dev/sdg
> (parted) print
> Model: DROBO DroboPro (scsi)
> Disk /dev/sdg: 17.6TB
> Sector size (logical/physical): 512B/512B
> Partition Table: gpt
> Number  Start  End  Size  File system  Name  Flags
> (parted)
> and looking at an example of creating a partition: (parted) mkpart primary
> 106 16179
> I dont know what to do next since I dont see any partitions listed. I dont
> know what do to for the start and end point, although the man page says
> "size in MB". Do I just say 0 to (and convert 16.0TB to MB? Yes, I
> know it
> says 17.6 TB but this model drobo can only support partitions up to 16tb
> without making a second partition.
> Can anyone provide some advice on that I am missing conceptually?

When I had to play with GPT for a 3TB disk, I did:
  gdisk -l /dev/sdc
  parted -s /dev/sdc mklabel gpt
  parted -s -a optimal /dev/sdc unit s mkpart primary ext4 2048 <MAXVALUE>

Not sure if optimal, but it worked...