[CentOS] [centos-6.3-desktop] Unable to login

Tue Apr 23 14:49:59 UTC 2013
Mayur Patil <ram.nath241089 at gmail.com>


  I have done following steps:

   Press Ctrl+Alt+F2

   By root login, I entered following command :

    yum groupinstall basic-desktop desktop-platform x11 fonts

   Then I reboot system; only blank screen appears ; not even cursor.

   Then I tried this :

   yum groupinstall -y ' X Windows System'

   yum groupinstall -y ' Desktop '

   Then I open */etc/inittab* via text editor and change following line:




    Then give command to start the GUI:

    $ init 5
    but screen stop responding after giving message " Starting jexec
services ".

   After that I reboot system, Then I run.

   $ startx

   It has loaded some packages but failed to load and stop there.

   Then I tried this gnome-session, gnome-panel and gnome-applets.

   It has said everything is installed.

   After this, I tried this:

   yum -y groupinstall "X Window System" "Desktop" "Fonts" "General Purpose

   upto 83 MB installation Then I reboot and entered startx

    it has given following error and stopped

   Loading extension GLX
   FATAL: Module fbcon not found.
   [dix] Could not init font path element catalogue:/etc/X11/fontpath.d,
removing from list!
   [dix] Could not init font path element built-ins, removing from list!

   Fatal server error: could not open default font 'fixed'
   (EE) Please consult the CentOS support  at
http://wiki.centos.org/Documentation  for help.
   (EE) Please also check the log file at "/var/log/Xorg.0.log" for
additional information.
   (EE) Server terminated with error (1). Closing log file.
   [89.274] (EE)
   [89.274] (II) AIGLX: Suspending AIGLX clients for VT switch

   Now as the last measure, I have run the

      yum -y update

   today itself. 243 MB, will get complete tomorrow (as per I hope).

   I have google for this but not find confirm solution.

   Am I missing something; please help ??

  Seeking for guidance,

  Thank you !!!