[CentOS] Problem getting mysqldump on Centos 5.x server

Wed Apr 24 01:42:05 UTC 2013
Clint Dilks <clint.dilks at gmail.com>

Hi Bruce

>From your message I am assuming that either you installed MySQL yourself or
had some do it for you?

Is the mysql database currently running?  If not it should be.
Are you able to access the database using the command line tools ?  From
the machine its currently running on try

mysql -p ( when prompted enter the password you believe should work)

If it is running I suggest you schedule a time to shut it down and reset
the root password
See http://dev.mysql.com/doc/refman/5.0/en/resetting-permissions.html or

Moving the physical files associated with a MySQL Database can be made to
work if you absolutely must.  But getting a mysql dump is a much cleaner

I hope this helps :)

On Wed, Apr 24, 2013 at 1:20 PM, Bruce Whealton
<bruce at futurewaveonline.com>wrote:

> Hello all,
>         I have a dedicated hosting account that I am closing down but I am
> having problems getting an access denied error when I run the mysqldump
> command from the ssh prompt, logged in as root.  So, the hosting provider,
> who saw the same error, reported, " Hence, we would suggest you directly
> the database from server to your machine by using ssh client."  I am not
> sure what that means.  Unless it means going into the /home/msyql directory
> and then into the corresponding directory for the particular db that I am
> trying to get.  This is for a joomla installation.  So, there are files
> that
> include db.opt and then jos_banner.frm, jos_banner.MYD, jos_banner.MYI, and
> etc.
> So, do I download all those files?
> I am wanting to move the site to another server which is a VPS hosting
> account that also runs Centos 5.x.
> Thanks in advance for any help,
> Bruce
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos