[CentOS] 3TB External USB Drive isn't recognized

Mon Aug 12 14:36:13 UTC 2013
m.roth at 5-cent.us <m.roth at 5-cent.us>

james wrote:
> We have a 3TB external USB drive that I am trying to attach to some
> CentOS5 servers. I have tried an older Dell PE1950 and a newer R310 but
> neither one seems to be able to read the drive. It works no problem
> on windows servers/workstations and I was able to format with NTFS.
> I know there are different methods for formatting large disks but this one
> doesn't even seem to show up as a /dev/ device. I supplied the dmesg
> output I see when I plug in the device. Is this a limitation of CentOS5?
> Do I need some additional package / driver / update?

First, let me say I've not used USB drives - we have an eSATA external bay
for backups. However, I've never had trouble with it. A few details:

1. You *MUST* use parted or gparted, and mklabel GPT; MBR can't deal
     with something over 2TB.
2. We've put a few 3TB SATA drives in servers, and no problems with any of
the servers recognizing them, including Dells. (I will note all our 1950's
are retired - they started having card problems a couple-three years ago,
one or two a month.)

3. Have you tried other USB ports? I believe that some are slower - maybe
the ones in the back might be faster, or there might be an internal faster
port for USB storage.