[CentOS] qemu-kvm package?

Wed Aug 14 01:29:48 UTC 2013
Dennis Jacobfeuerborn <dennisml at conversis.de>

On 09.08.2013 22:38, Dave Johansen wrote:
> On Fri, Aug 9, 2013 at 9:03 AM, Dennis Jacobfeuerborn
> <dennisml at conversis.de> wrote:
>> On 09.08.2013 17:39, Dave Johansen wrote:
>>> On Fri, Aug 9, 2013 at 8:24 AM, Patrick Hurrelmann
>>> <patrick.hurrelmann at lobster.de> wrote:
>>>> On 09.08.2013 17:21, Dave Johansen wrote:
>>>>> On Fri, Aug 9, 2013 at 8:15 AM, lists-centos
>>>>> <replies-lists-c9y6-centos at listmail.innovate.net> wrote:
>>>>>> ------------ Original Message ------------
>>>>>>> Date: Friday, August 09, 2013 08:04:08 AM -0700
>>>>>>> From: Dave Johansen <davejohansen at gmail.com>
>>>>>>> To: CentOS mailing list <centos at centos.org>
>>>>>>> Cc:
>>>>>>> Subject: [CentOS] qemu-kvm package?
>>>>>>> I just did a clean net install of CentOS 6.4 and when I run
>>>>>>> virt-manager it says that qemu-kvm is missing, but when I try to
>>>>>>> install it with yum it says that there isn't a package with that
>>>>>>> name. Is something wrong with my configuration? Or what is causing
>>>>>>> this package to appear as not available? Thanks,
>>>>>>> Dave
>>>>>> Is this install on a 32-bit machine?
>>>>>> It's there for 64-bit, but I don't see it for 32-bit.
>>>>>>      - Richard
>>>>> It's a 32-bit install.
>>>> kvm is not supported on 32bit installs in rhel/centos.
>>> Really? Is there a reason why that is the case? Because the hardware
>>> supports it and so is it just that the software doesn't support
>>> 32-bit? That's kind of surprising because my experience has usually
>>> been that if both weren't supported then it was 64 bit that was
>>> lacking.
>> Nowadays you should always install 64 bit. 32 bit is a legacy
>> architecture and should not be used unless you absolutely have no other
>> choice.
> Unfortunately, for me that is the case. The laptop I was doing this on
> (Thinkpad T60) doesn't support x64.
> But the "32 bit is legacy" argument seems a bit odd and that's the
> first time I've heard that. Maybe I'm just a bit out of that loop, but
> the reason I say that is that before doing this install, I had Fedora
> 19 on the machine and kvm worked just fine on the machine, so if it
> really was that "32 bit" wasn't being supported for things like kvm
> anymore, then why does a "cutting edge" system like Fedora 19 have
> support for it?

The important thing here is the different possible meanings of the word 
"support". Fedora doesn't support things in the same way RHEL/CentOS 
does. In Fedora "supports X" means "is technically capable of doing X" 
however in enterprise distros support actually means that the company 
guarantees (within limits) that X works and if it doesn't work for a 
customer it expends engineering resources to fix whatever the problem is.

In the case of 32bit vs 64bit KVM Red Hat simply decided that it doesn't 
want to incur all the trouble/costs it would take to actually name 32bit 
KVM as supported since 98% of the systems KVM will be used on nowadays 
are 64bit capable.

Since Fedora does have to deal with these issues only on a "we'll try to 
keep things working but if we fail you are on your own" basis they 
probably have no reason to disable 32bit support.

My guess is that if you flip a few switches in the source kernel and 
qemu/kvm packages to compile in the 32bit modules you should be able to 
make it work but I haven't dealt with a 32bit system in years so I'm not 
sure if this is enough to get things going.