[CentOS] minimal X applications needed to export to remote server?

Fri Aug 16 15:30:32 UTC 2013
Les Mikesell <lesmikesell at gmail.com>

On Fri, Aug 16, 2013 at 10:17 AM, Joseph Spenner <joseph85750 at yahoo.com> wrote:
> I'm running a piece of network backup software called 'bacula', on a minimal CentOS 6.4 install.
> I got everything working pretty well, but there's one piece giving me some problem-- a component which gives status info via a GUI.
> In the past, on previous installations, I could ssh to the bacula server with the -X option, and run the application (called 'bat'), and it would display back.  I'd have to make sure the sshd_config permits Xforwarding, but that was all.
> On my new CentOS 6.4 minimal, I always get:
> bat: cannot connect to X server
> I tried the usual tricks of exporting the display to my system where I want to see the GUI, which shouldn't be necessary anyway due to the 'ssh -X', but I thought I'd give it a shot.  Still no go.

Did you try -Y instead of -X?   It has never been clear to me which
things need -Y so I generally just use -Y all the time.  Also adding
-v or -vv to the ssh args will sometimes show the details about what
is failing.  You probably need the xorg-x11-xauth package if you don't
have it.

  Les Mikesell
    lesmikesell at gmail.com