[CentOS] Latest chromium i686 - Illegal Instruction

Tue Aug 27 14:12:51 UTC 2013
Trutwin, Joshua <JTRUTWIN at CSBSJU.EDU>


I recently upgraded chromium on a 32-bit CentOS 6.4 system yesterday to version to chromium-28.0.1500.95-213514.i686.  I then ran the chrome_pepperflash_copy.sh script, but my copy of the script was before it was modified to check the architecture so it downloaded the 64 bit chrome rpm and installed that version of pepper.  I tried to run chromium but was greeted with "Illegal Instruction (core dumped)".  I then noticed the 64-bit rpm was downloaded so I removed /opt/chromium/PepperFlash and completely re-installed chromium.i686.  No go.  So I then cleaned up /tmp, rebooted and removed ~/.cache/google-chrome and ~/.config/chrome.  Unfortunately it is still crashing.  I'm not sure if it has to do with the updated version or the botched 64-bit pepperflash installation, the script doesn't seem to do anything other than create /opt/chromium/PepperFlash and update the .desktop file.

I ran an strace of /opt/chromium/chrome-wrapper and put it here: http://pastie.org/8272854 - it's always crashing on statfs64("/selinux", ....) - not sure 
what that means though.  /selinux exists, selinux is actually disabled.

Anyone else having issues like this?

Thank you,