[CentOS] Can't install Python i686 on x86_64 system (centos 6.5)

Brian Bernard brian.brianbernard at gmail.com
Mon Dec 2 02:59:50 UTC 2013


Hello,

This is my first time posting to the list adn I've run into a problem
trying to install python-2.6.6-51.el6.i686 on my x86_64 bit system, which I
updated to CentOS 6.5 this evening. I receive the following error:

error: Failed dependencies:
    libpython2.6.so.1.0 is needed by python-2.6.6-51.el6.i686
    python-libs(x86-32) = 2.6.6-51.el6 is needed by python-2.6.6-51.el6.i686
    libpython2.6.so.1.0 is needed by python-devel-2.6.6-51.el6.i686

Now I've downloaded the python and python-devel i686 versions from a mirror
and tried to install locally with 'sudo rpm -Uvh python-2.6.6-51.el6.i686
python-devel-2.6.6-51.el6.i686', but I always receive the same error.

I tried 'sudo yum install python-2.6.6-51.el6.i686
python-devel-2.6.6-51.el6.i686 with again the same error.

Brian Bernard



More information about the CentOS mailing list