[CentOS] Issue mounting /home area from NAS server

m.roth at 5-cent.us m.roth at 5-cent.us
Thu Dec 5 19:35:16 UTC 2013

Mike Burger wrote:
>>> Just before the Thanksgiving break, we enabled quotas on
>>> the /home areas on the mseas-data server (running CentOS 5.8),
>>> using the following line in the updated /etc/fstab
>>> /dev/mapper/the_raid-lv_home /home              ext3
>>> defaults,usrquota,grpquota      1 0
>>> Following the Thanksgiving reboot of mseas-data we have been
>>> experiencing problems with svn on mseas (our front-end machine,
>>> running CentOS 6.2). After consulting with the svn mailing list,
>>> it appeared to be a communication issue between mseas and mseas-data.
>>> We therefore rebooted mseas. Now mseas is not mounting /home.
>>> We get the following error
>>> [root at mseas etc]# mount mseas-data:/home
>>> mount.nfs: Unknown error 521
>>> We have tried this mounting with both of the following lines
>>> in fstab and got the same error
>>> mseas-data:/home        /home               nfs     defaults        0 0
>>> mseas-data:/home        /home               nfs
>>> defaults,usrquota,grpquota        0 0
> By which NFS version are you exporting from the mseas-data server...v3 or
> v4?
> If v3, you may have to add "vers=3" to the options section of your fstab.
> Try manually mounting with -o vers=3 in the command line to see if this
> fixes things.

Also, are any of the directories you want to mount ext4? I just had a
problem the other week, where I had copied a line in /etc/fstab, and
hadn't changed it to ext4 (it was a 3TB drive I'd added), and it wouldn't
mount till I changed that.



More information about the CentOS mailing list