[CentOS] Can't install Python i686 on x86_64 system (centos 6.5)

Mon Dec 2 03:58:33 UTC 2013
Akemi Yagi <amyagi at gmail.com>

On Sun, Dec 1, 2013 at 6:59 PM, Brian Bernard
<brian.brianbernard at gmail.com> wrote:
> Hello,
> This is my first time posting to the list adn I've run into a problem
> trying to install python-2.6.6-51.el6.i686 on my x86_64 bit system, which I
> updated to CentOS 6.5 this evening. I receive the following error:
> error: Failed dependencies:
>     libpython2.6.so.1.0 is needed by python-2.6.6-51.el6.i686
>     python-libs(x86-32) = 2.6.6-51.el6 is needed by python-2.6.6-51.el6.i686
>     libpython2.6.so.1.0 is needed by python-devel-2.6.6-51.el6.i686

Up to CentOS 6.4, python.i686 was included in the x86_64 tree. This is
not the case with CentOS 6.5, thus the error. [By the way, RHEL 6.5
does not have python.i686 in the x86_64 repo.]

> Now I've downloaded the python and python-devel i686 versions from a mirror
> and tried to install locally with 'sudo rpm -Uvh python-2.6.6-51.el6.i686
> python-devel-2.6.6-51.el6.i686', but I always receive the same error.

If you include python-libs.i686 in the mix, it may go further.