[CentOS] Issue mounting /home area from NAS server

Thu Dec 5 19:02:59 UTC 2013
Mike Burger <mburger at bubbanfriends.org>

> Hi,
> A quick follow-up.  I tried reverting back to the
> set ups on both machines before we enabled quotas.
> Rebooted both machines.  Still cannot mount /home
> from the client (mseas).
> Thanks.
>> Hi,
>> Just before the Thanksgiving break, we enabled quotas on
>> the /home areas on the mseas-data server (running CentOS 5.8),
>> using the following line in the updated /etc/fstab
>> /dev/mapper/the_raid-lv_home /home              ext3
>> defaults,usrquota,grpquota      1 0
>> Following the Thanksgiving reboot of mseas-data we have been
>> experiencing problems with svn on mseas (our front-end machine,
>> running CentOS 6.2). After consulting with the svn mailing list,
>> it appeared to be a communication issue between mseas and mseas-data.
>> We therefore rebooted mseas. Now mseas is not mounting /home.
>> We get the following error
>> [root at mseas etc]# mount mseas-data:/home
>> mount.nfs: Unknown error 521
>> We have tried this mounting with both of the following lines
>> in fstab and got the same error
>> mseas-data:/home        /home               nfs     defaults        0 0
>> mseas-data:/home        /home               nfs
>> defaults,usrquota,grpquota        0 0
>> (the latter was to mimic the mounting of /home on mseas-data)
>> The only thing we've found out on the web so far was advice
>> on editting /etc/exports to have an "insecure" option for
>> the export of /home, which we already had.
>> Any thoughts on how to resolve or debug this issue would
>> be greatly appreciated.

By which NFS version are you exporting from the mseas-data server...v3 or v4?

If v3, you may have to add "vers=3" to the options section of your fstab.
Try manually mounting with -o vers=3 in the command line to see if this
fixes things.

Mike Burger

"It's always suicide-mission this, save-the-planet that. No one ever just
stops by to say 'hi' anymore." --Colonel Jack O'Neill, SG1