[CentOS] Upgrade to CentOS 6.5 -> issue with Broadcom Wifi

Tue Dec 10 11:55:26 UTC 2013
Milos Blazevic <milos.blazevic at sbb.rs>

On 12/10/2013 10:45 AM, wwp wrote:
> Again,
> On Tue, 10 Dec 2013 10:26:19 +0100 wwp <subscript at free.fr> wrote:
>> I was running CentOS 6.4 system on my Dell Latitude E6530 flawlessly,
>> until I upgraded to CentOS 6.5.
>> Now the wifi doesn't show up (it's a Broadcom Wifi BT4313, 14e4:4727), I
>> tried to follow the steps from http://wiki.centos.org/HowTos/Laptops/Wireless/Broadcom
>> but when attempting to compile the Broadcom driver module, the make
>> command fails in a way that is not described on this web page. Anyway,
>> the page deals w/ CentOS5 without being specific.
>> I tried w/ both hybrid-portsrc_x86_64-v5_100_82_112.tar.gz (the one
>> which *I think* was formerly installed) and the latest available:
>> hybrid-v35_64-nodebug-pcoem-6_30_223_141.tar.gz; same compilation
>> errors (see below).
>> I simply could not remember how I had the Broadcom Wifi chip working
>> since CentOS 6.x, but I clearly remember that I had to install
>> the driver (I presume from the sources since I've found them in my
>> setup archives, but not sure). I have the following RPM's installed:
>>    b43-openfwwf-5.2-4.el6.noarch
>>    b43-fwcutter-012-2.2.el6.x86_64
>> I wonder if the kernel update breaks it.. Does any one have experience
>> with this driver and CentOS 6.5?
> More data:
> it seems that I had formerly followed steps from http://elrepo.org/tiki/wl-kmod,
> as I could find kmod-wl-5_100_82_112-9.el6.el6.local.x86_64.rpm installed locally,
> and RPM assembly stuff in ~/rpmbuild/.
> No better idea why it doesn't work since CentOS 6.5, unfortunately!
In that case you should rebuild the RPM from the latest sources from 
Broadcom and src.rpm from ELrepo and you'll find the chip working again.

*Milos Blazevic*


Cert. No: 805010564450148