[CentOS] Upgrading Python with NumPy, SciPy and Mayavi on a CentOs 6.2 (Rocks 6.0) cluster

Patrick Haley phaley at MIT.EDU
Sun Jan 13 18:06:00 UTC 2013


Hi,

We are looking for some guidance in installing an upgraded
Python on our cluster.  Our cluster was installed with Rocks 6.0,
is running CentOs 6.2, and has python-2.6.6, gcc-4.4.6.  We
would like to install an upgraded version of Python along with
the following modules

NumPy
Scipy   (which will require a compatible version of the Atlas libraries)
Mayavi  (which will require a compatible version of vtk)

We were wondering if anyone has experience in installing these
packages, what are the best combinations of compatible versions,
what other upgrades will be needed (e.g. will we need to
upgrade the gnu compilers to install the latest versions) and
where these should be installed (local disks, /share/apps, other?).

A little more background, our students are currently working
with a local installation using

Python-2.7.1
numpy-1.5.1
scipy-0.9.0b1
Mayavi-3.4.0
ATLAS-3.8.3
vtk-5.4

We would like to install these packages in a more
appropriate, cluster-wide area and upgrade these
packages as appropriate.  We are also aware of a
Rocks python roll which contains python-2.7.2 and
an upspecified version of NumPy (is it possible to
find out which version, before installing the roll?).

Thanks


-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Pat Haley                                                  Email:     phaley at mit.edu
Center for Ocean Engineering                     Phone:    (617) 253-6824
Dept. of Mechanical Engineering                 Fax:        (617) 253-8125
MIT, Room 5-213                                      http://web.mit.edu/phaley/www/
77 Massachusetts Avenue
Cambridge, MA  02139-4301




More information about the CentOS mailing list