[CentOS] Serial console

Tracy Reed treed at ultraviolet.org
Sat Jan 19 01:09:25 UTC 2013


I am trying to get a CentOS 6.3 serial console to work with IPMI SOL. I think I
have everything working but maybe the wrong baud rate on the getty:

$ ipmitool -I lanplus -U root -H 10.0.0.14 sol activate
Password:
[SOL Session operational.  Use ~? for help]
����������

10.0.0.14 is the DRAC IP address of the CentOS 6.3 box. It accepts the password
and connects me to the console but then when I type I get those funny
characters. Somehow an agetty is already being run:

root     46110     1  0 16:13 ttyS1    00:00:00 /sbin/agetty /dev/ttyS1 19200 vt100-nav

Is udev starting this up for me somehow? It says 19200 when everything I have
read says it should be 115200. How do I change this? Some docs say I should
create my own /etc/init/serial-ttyS1.conf containing:

# For IPMI serial console
# ttyS1 - agetty
#
# This service maintains a agetty on ttyS1.

stop on runlevel [S016]
start on runlevel [23]

respawn
exec agetty -h -L -w /dev/ttyS1 115200 vt102

but when I do that I end up with two gettys, presumably fighting over the
serial port, and the original is apparently holding onto it because I still
can't connect and get a login prompt.

# ps -ef |grep agetty
root     46110     1  0 16:13 ttyS1    00:00:00 /sbin/agetty /dev/ttyS1 19200 vt100-nav
root     46118     1  0 16:13 ?        00:00:00 agetty -h -L -w /dev/ttyS1 115200 vt102

What is the right way to set this up?

Thanks!

-- 
Tracy Reed



More information about the CentOS mailing list