[CentOS] Not respected repo priorities...

John Doe jdmls at yahoo.com
Mon Jan 28 14:00:19 UTC 2013


Ah ah, the demo effect... just after I said I did not have much issues with repos... ^_^
A collegue installed some packages (for perconna) and since then a server insists on replacing 2 base packages with 2 rfx packages, even when I gave a lower priority to rfx...

Installed: perl-IO-Compress-Base-2.020-127.el6.x86_64
Installed: 1:perl-Compress-Raw-Zlib-2.020-127.el6.x86_64
Installed: perl-IO-Compress-Zlib-2.020-127.el6.x86_64
Installed: perl-Compress-Zlib-2.020-127.el6.x86_64
Installed: perl-HTML-Tagset-3.20-4.el6.noarch
Installed: perl-HTML-Parser-3.64-2.el6.x86_64
Installed: perl-libwww-perl-5.833-2.el6.noarch
Installed: perl-Params-Validate-0.92-3.el6.x86_64
Installed: perl-Log-Dispatch-2.26-1.el6.rf.noarch
Installed: perl-Parallel-ForkManager-0.7.5-2.2.el6.rf.noarch
Installed: 4:perl-Time-HiRes-1.9721-127.el6.x86_64
Installed: perl-Config-Tiny-2.12-7.1.el6.noarch


# yum update
Loaded plugins: changelog, fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * epel: mirror.affix.me
 * rpmforge: archive.cs.uu.nl
 * rpmforge-extras: archive.cs.uu.nl
rpmforge                                                                                                                                                                                                                                                      | 1.9 kB     00:00     
rpmforge-extras                                                                                                                                                                                                                                               | 1.9 kB     00:00     
1913 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Compress-Zlib.x86_64 0:2.020-127.el6 will be obsoleted
---> Package perl-IO-Compress.noarch 0:2.037-1.el6.rfx will be obsoleting
--> Processing Dependency: perl(Compress::Raw::Bzip2) = 2.037 for package: perl-IO-Compress-2.037-1.el6.rfx.noarch
--> Processing Dependency: perl(Compress::Raw::Zlib) = 2.037 for package: perl-IO-Compress-2.037-1.el6.rfx.noarch
---> Package perl-IO-Compress-Base.x86_64 0:2.020-127.el6 will be obsoleted
---> Package perl-IO-Compress-Zlib.x86_64 0:2.020-127.el6 will be obsoleted
--> Finished Dependency Resolution
Error: Package: perl-IO-Compress-2.037-1.el6.rfx.noarch (rpmforge-extras)
           Requires: perl(Compress::Raw::Bzip2) = 2.037
           Available: perl-Compress-Raw-Bzip2-2.020-127.el6.x86_64 (base)
               perl(Compress::Raw::Bzip2) = 2.020
Error: Package: perl-IO-Compress-2.037-1.el6.rfx.noarch (rpmforge-extras)
           Requires: perl(Compress::Raw::Zlib) = 2.037
           Installed: 1:perl-Compress-Raw-Zlib-2.020-127.el6.x86_64 (@base)
               perl(Compress::Raw::Zlib) = 2.020
 You could try using --skip-broken to work around the problem


Is it a yum/priority bug or a repoforge bug?

I suspect it might be due to the new fedora release?
Doesn't priority also blocks obsoleted/obsoleting packages...?
I did a clean all...


Thx, 

JD




More information about the CentOS mailing list