[CentOS] yum killed, ipa\* and xorg\* a mess

Tue Jan 29 18:45:55 UTC 2013
Zube <Zube at stat.colostate.edu>

On Mon Jan 28 08:20:55 AM, Zube wrote:

Follow-up, for the archives:

> yum update was killed at an inopportune time, leaving ipa\* and xorg\*
> in an inconsistent state.  
> yum-complete-transaction looks like it it's going to erase the entire 
> system and then fails.
> >From the transaction files, the following are in:
> install 0:ipa-python-2.2.0-17.el6_3.1.x86_64
> install 0:ipa-client-2.2.0-17.el6_3.1.x86_64
> install 0:xorg-x11-server-common-1.10.6-1.0.1.el6.centos.x86_64
> install 0:ipa-admintools-2.2.0-17.el6_3.1.x86_64
> rpm -q ipa-server returns:
> ipa-server-2.2.0-16.el6.x86_64
> ipa-server-2.2.0-17.el6_3.1.x86_64
> rpm -q ipa-server-selinux returns:
> ipa-server-selinux-2.2.0-16.el6.x86_64
> Thinking I could remove the old and then drop in the new, I tried:
> rpm -e ipa-server-2.2.0-16.el6.x86_64 ipa-server-selinux-2.2.0-16.el6.x86_64
> but that fails with:
> ipa-server-selinux = 2.2.0-17.el6_3.1 is needed by (installed) ipa-server-2.2.0-17.el6_3.1.x86_64

Taking both ipa-server's out:

rpm -e ipa-server-2.2.0-16.el6.x86_64 ipa-server-selinux-2.2.0-16.el6.x86
_64 ipa-server-2.2.0-17.el6_3.1.x86_64

worked.  I was then able to:

yum install ipa-server

followed by rpm -e the other ipa\* and xorg\* duplicates that were listed,
to get things back to a consistent state.  I also ran:

yum check 

for good measure.  


1) yum-complete-transaction is not a silver bullet.

2) Don't order the Kill Yum Special at the Derhay Cafe.