[CentOS] Need a Centos 6 USB hard drive recovery procedure

Sat Jun 1 15:08:51 UTC 2013
Rock <Rocksockdoc at gmail.com>

On Sat, 01 Jun 2013 12:25:01 +0200, Louis Lagendijk wrote:

>> Should I now format the 2TB disk using this command?
>>  $ sudo mkfs /dev/sdb1
> You could try without reformatting it: just check where it is mounted:
> mount |grep sdb1 

Thanks for your patience. I backed up the spare 500MB USB disk, so, 
I'm about to run the procedure on the "bad" 150MB disk as we type.

Plugging in the spare 500MB disk, I run the suggested command:
a. Open a wide window & type "sudo tail -f /var/log/messages"
b. Plug in the spare 500MB USB disk & look for where it mounted:
==> Jun  1 07:42:41 rock ntfs-3g[5834]: 
==> Mounted /dev/sdb1 (Read-Write, label "SignatureMini", NTFS 3.1)
==> Cmdline options: rw,nosuid,nodev,uhelper=udisks,uid=503,gid=503,dmask=0077
==> Mount options: rw,nosuid,nodev,uhelper=udisks,allow_other,nonempty,atime,
==> Global ownership and permissions enforced, configuration type 1
c. $ mount | grep sdb1 
==> /dev/sdb1 on /media/SignatureMini type fuseblk (rw,nosuid,nodev,

>> And then mount it as:
>>  $ sudo mount /dev/sdb1 /mnt

It won't mount because it's already mounted:
$ sudo mount /dev/sdb1 /mnt
==> Mount is denied because the NTFS volume is already exclusively opened.
==> The volume may be already mounted, or another software may use it which
==> could be identified for example by the help of the 'fuser' command.

Maybe I should umount it first?
$ sudo umount /dev/sdb1
$ mount | grep sdb1 
==> now reports nothing

OK. Now I'll mount it as you kindly suggested:
$ sudo mount /dev/sdb1 /mnt
$ mount | grep sdb1 
==> /dev/sdb1 on /mnt type fuseblk (rw,allow_other,blksize=4096)

Note: The funny thing was that the second time I tried that, 
it asked for the file system type:
$ sudo mount /dev/sdb1 /mnt
==> mount: you must specify the filesystem type

So, I specified the filesystem type:
$ sudo mount -t fuseblk /dev/sdb1 /mnt
==> mount: special device /dev/sdb1 does not exist

Hmmm... I'll reboot and try again because I tried a few
options for specifying the filesystem type and all failed.

Sending this out ... so it's not lost ... and then rebooting
and trying again. Thanks for your help. I'll try to be responsive
and detailed so that we can come up with a procedure that not
only works for me, but that works for others on Centos.