[CentOS] LVM + XFS + external log + snapshots - SOLVED

Tue Jun 25 02:49:21 UTC 2013
aurfalien <aurfalien at gmail.com>

On Jun 21, 2013, at 2:58 PM, Joseph L. Casale wrote:

>> So I have an XFS file system within LVM  which has an external log.
>> A snapshot volume is created w/o issue;
>> But when i try to mount the file system;
>> mount: /dev/mapper/vg_spock_data-datasnapshot already mounted or /snapshot busy
> So the filesystem was built requiring an external log device?
> Let me guess, the original block device is still mounted and accessing its log device?
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

So this worked;

truncate --size=2G logfile
losetup /dev/loop0 logfile
mount /dev/vg_anette_data/datasnapshot /snapshot -o logdev=/dev/loop0,nouuid,ro

Freezing the fs looks to make the log zero.  So assigning any device/file for the external log would work.

My mistake was not making the log dev an LVM.  However I don't if a log on an LVM would have worked anyways.

At any rate, HTH some one else.

- aurf