[CentOS] updating to 6.4 broke olvwm/openwin

Thu Mar 21 21:36:56 UTC 2013
Miranda Hawarden-Ogata <hawarden at ifa.hawaii.edu>

On 2013/03/21 11:18, m.roth at 5-cent.us wrote:
> Miranda Hawarden-Ogata wrote:
>> This morning a handful of workstations got upgraded from 6.3 to 6.4 and
>> things seemed to be functional, until we tried to log in to one of our
>> instrument accounts that for various reasons uses olvwm/openwin as the
>> desktop (and no, I don't have the option of changing that at this time).
>> The desktop appears to load correctly, and mouse-focus and clicking
>> appears to work, but the .openwin-menu entries no longer function other
>> than clicking "exit" to log out of the session. I've tried reinstalling
>> xview and xview-client rpms, but that doesn't resolve it. I don't think
>> it's an issue with the user account, as the underlying commands work
>> when I su and execute them in an xterm. I was also able to reproduce the
>> problem on three separate computers.
>> I don't usually have to deal with these desktop issues so I'm hella
>> rusty when it comes to debugging them. Does anyone have any tidbits to
>> point me in the right direction to fix this? (Hopefully soon, since we
>> are supposed to use this account for observations tonight)
> Could there be a) a permission problem; b) is selinux enabled? c) how are
> the home directories mounted (I assume that/s where the .openwin-menu
> files are).
> Observatory? Kek? Mauna Kea?
>          mark
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
Keck?!? Heck no! X__X LOL! Nope, we're right next door: IRTF.

a) permission problem: permission on what? .openwin-menu? .openwin-menu 
hasn't changed since 2008, .openwin-init since 2006... I haven't changed 
anything other than do "yum upgrade" and the problem is affecting all 
accounts that use openwin, across every machine that got upgraded.

b) selinux: disabled

c) home directories are automounted via nfs, v3 I believe. And 
.openwin-menu is indeed in /home/acct/.