[CentOS] updating to 6.4 broke olvwm/openwin

Fri Mar 22 19:39:38 UTC 2013
Miranda Hawarden-Ogata <hawarden at ifa.hawaii.edu>

On 2013/03/21 11:44, Johnny Hughes wrote:
> On 03/21/2013 04:06 PM, Miranda Hawarden-Ogata wrote:
>> This morning a handful of workstations got upgraded from 6.3 to 6.4 and
>> things seemed to be functional, until we tried to log in to one of our
>> instrument accounts that for various reasons uses olvwm/openwin as the
>> desktop (and no, I don't have the option of changing that at this time).
>> The desktop appears to load correctly, and mouse-focus and clicking
>> appears to work, but the .openwin-menu entries no longer function other
>> than clicking "exit" to log out of the session. I've tried reinstalling
>> xview and xview-client rpms, but that doesn't resolve it. I don't think
>> it's an issue with the user account, as the underlying commands work
>> when I su and execute them in an xterm. I was also able to reproduce the
>> problem on three separate computers.
>> I don't usually have to deal with these desktop issues so I'm hella
>> rusty when it comes to debugging them. Does anyone have any tidbits to
>> point me in the right direction to fix this? (Hopefully soon, since we
>> are supposed to use this account for observations tonight)
> There is a newer version of xorg-x11-server with 6.4 ... maybe you need
> to recompile your window manager with the newer devel files.

Thanks for the suggestion. I did try downgrading xorg-x11-server (and 
all its little friends) to the 6.3 versions, but that did not fix the 
problem. I've also tried rebuilding the xview set from the src rpm, but 
I wasn't able to get it to build in the not-too-long while that I spent 
on it yesterday.

On the bright-ish side, my sup is kind of saying: we were planning to go 
this route eventually, maybe we just do it now. I just wish it had been 
on ~my~ schedule! Thankfully I don't have ~too~ many accounts to revamp 
and people to educate on the 'new' desktops.