[CentOS] nscd

Mon Mar 25 21:32:32 UTC 2013
Cliff Pratt <enkiduonthenet at gmail.com>

On Tue, Mar 26, 2013 at 6:26 AM,  <m.roth at 5-cent.us> wrote:
> Has anyone had problems accessing random websites since going up to 6.4?
> Since about the day after I got partly upgraded, if I try to access
> nytimes.com, or orbitz.com, I get server not found.
> With a lot of work, I, my manager, and the other admin, found that setting
> options edns0 in /etc/resolv.conf fixed it - I suspect that the network
> folks updated their internal nameservers (which are M$) about that time...
> but... we got this Thurs. Friday, I went to look, lunchtime, at a story,
> and back to the same. Later, and I think I was playing around, it came
> back.
> Just now, over lunch, it failed... until I restarted nscd. My manager
> tells me it's caching... but it seems to be caching momentary failures.
> So: has anyone else seen oddness that might be related to nscd?
Do you want the whole book? 'nscd' is a synonym for weird. I've had
many strange DNS issues which have been solved by either bouncing nscd
or purging its cache entries.

However, you appear to be using nscd on your machine to cache DNS and
using the internal MS DSN servers to do the actual lookups. Am I
correct? In which case, the MS DNS server should be caching the DNS
lookups anyway, so you probably don't derive a lot of benefit from the
nscd unless you do a lot of repeated DNS lookups.