[CentOS] Help with thread Centos 6.4 won't reboot on install

Sat Mar 30 16:14:56 UTC 2013
Robert Benjamin <benjie1 at cox.net>

On 3/29/2013 4:09 PM, m.roth at 5-cent.us wrote:
> Robert Benjamin wrote:
>> On 3/29/2013 3:31 PM, Les Mikesell wrote:
>>> On Fri, Mar 29, 2013 at 12:10 PM, Robert Benjamin <benjie1 at cox.net>
>>> wrote:
>>>> looked in /var/log/yum.log and /var/log/Xorg.0.log  permission denied
>>>> chmod a+x OK got list of time stamped and at bottom I tried yum install
>>>> one of the items there. Got 'no package name '.
>>> You need to do most of this as root.  Carefully...  I am logged in as
>>> root
> For administration, either log in as root, or sudo -s, which will make you
> root (but leave a trail in the logs of what you did... which might be
> helpful for oopses.
> Just about everything in /var/log is root-only readable. You shouldn't
> change that, for security reasons.
> <snip>
>>>> Tried again to find .X0-lock and no luck. Hope I didn't make
>>>> things worse.
> Right. One of the few things that really annoys me about Linux is that the
> old std, at least where I worked, for ll was ls -laF, *not* ls -lF. I
> really *do* want to see hidden files, and the permissions/ownerships of
> the directories I'm looking at.
> If you'd find that convenient, edit your .bashrc, or whatever, to add
> alias ll="ls -laF"
> I've also not seen anywhere that
> h=history
> wasn't the case, except for linux....
> <snip>
>>>> Yum update said no packages set for install and yum
>>>> install (from time stamped items) said 'no package available' with the
>>>> name and numbers  from a time stamped line picked at random.
>>> Your yum remove command may also have been interpreted oddly if you
>>> had the space after /tmp.
>>> Normally you would just give the base package name to install,
>>> stopping before the -version-number part.
>>> For example if your log says yum removed gnome-disk-utility.i686
>>> 0:2.30.1-2.el6 you would get it back with
>>> yum install gnome-disk-utility.
>>       I never got a nice neat list lie what you have above .Maybe I had
>> another error when I tried to look in /var/log/yum.log  What is the best
>> command to use to look in here?
> tail /var/log/yum.log
> or
> view /var/log/yum.log
> DO NOT EDIT IT... which is why I used view, to default to uneditable. You
> can, of course, force it, but it warns you.
>        mark
     as root. first did rm /tmp/.X0-lock    got remove regular file 
'/tmp/.X0-lock'? -  typed y and got back to the root login prompt where 
I started. Guess that was ok.

   Next typed cat /var/log/yum.log  Got the list you mentioned, and the 
date where I made the error had things marked with 'erased'. It was as 
long as the list I erroneously removed, so I did yum install filename 
for each one and they all worked. Here is the list that was re-installed:

> basesystem, system-config-kdump, dracut-kernel, kexec-tools, dracut, nautilus-sendto, file-roller, totem-nautilus, evince, xinetd, gnome-user-share, brasero-nautilus, gnome-disk-utility, nautilus-open-terminal, nautilus, nautilus-extensions, filesystem
     then, typed /var/log/Xorg.0.log and at the bottom it listed the 
files above as 'installed'. The same ones that were previously marked as 
'Erased' So hopefully that is good. Had to shut down and do errand and 
back now but haven't tried anything yet.

> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos