[CentOS] Cannot mount 3TB MyBook USB HD

Fri Mar 8 21:32:07 UTC 2013
Miller,Jason [Burlington] <J.Miller at ec.gc.ca>

Hello, new Linux user here and I cannot mount a new (empty) WD MyBook
Essentials 3TB USB external hard drive (Model WDBACW0030HBK-NESN).

I'm only about 3 weeks into this linux thing and so please forgive me if
any of my syntax is off


My linux OS is CentOS  5.4 x86-64 running on a dedicated HP z400. The WD
MyBook is to back up the large data files we are creating on the HP400
(it's used to run a DNA sequencer)


I plugged the brand new MyBook into my XP system  and cleaned out all
the pre-installed WD files as soon as I got it, then plugged into my
Linux system (2 completely separate machines). It failed to auto-mount
with this error:


Failed to read last sector (732558079): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?



I've been searching in many forums and such but so far nothing I've
tried has worked, including:


Reformatting the HD (on the XP machine), NTFS format using 4096 byte
allocation size (slow format, took hours)

Reformatting the HD (on the XP machine), NTFS format using 512 byte
allocation size (that the size used on the two ext3 internal drives;
used "quick format" option this time)


Adding a new directory:

# mkdir /media/MyBook


Then changing fstab to add line:

/dev/sdc1           /media/MyBook              ntfs-3g
rw,umask=0000,defaults              0 0



# mount /media/MyBook


Which returned the same error each time


I installed gparted, then opened the GUI program. It nicely displays the
info on the two installed ext3 hard drives but that's all it shows


Here's some info on other packages which were investigated,  installed
or updated in an attempt to mount this USB drive:

ntfs-3g would not install, yum reported conflicts with fuse-ntfs-3g

dkms-fuse is not installed

dkms not installed

fuse-ntfs-3g (updated to latest version)

parted (updated to latest version)


When  I run

# parted /dev/sdc 


# parted /dev/sdc1

I get this message:

Warning: Device /dev/sdc has a logical sector size of 4096.  Not all
parts of GNU Parted support this at the moment, and the working code is


When I use "print" command in gparted I get

Error: unable to open /dev/sdc (or /dev/sdc1) - unrecognized disk label


I also tried fdisk

# fdisk /dev/sdc

And received this message:

The number of cylinders for this disk is set to 45599. There is nothing
wrong with that, but this is larger than 1024, and could in certain
setups cause problems with:

1) software that runs at boot time (e.g., old versions of LILO)

2) booting and partitioning software from other Oss (e.g., DOS FDISK,


WARNING: The size of this disk is 3 TB 

DOS partition table format can not be used on drives for volumes larger
than (2199023255040 bytes) for 512-byte sectors. Use parted(1) and GUID

partition table format (GPT).



Similar results when I used

# fdisk /dev/sdc1

Except some number were different (ie number of cylinders report as


What am I doing wrong? Is all this problem simply due to the size of the
hard drive (3TB)? I also have a 1TB Seagate used to backup several other
computers (all XP or Win7). Would I be better to use the Seagate on the
linux and the WD on the windows systems?




Jason Miller

J.Miller at ec.gc.ca <mailto:J.Miller at ec.gc.ca> 


Aquatic Contaminants Research Division

National Water Research Institute
Environment Canada - Canada Centre for Inland Waters
867 Lakeshore Rd.
Burlington, Ontario, Canada
L7R 4A6