[CentOS] Kickstart and volume group with a dash in the name

Fri May 3 13:36:15 UTC 2013
m.roth at 5-cent.us <m.roth at 5-cent.us>

Dennis Jacobfeuerborn wrote:
> On 02.05.2013 18:33, maxxik wrote:
>> On 03/05/13 00:13, Dennis Jacobfeuerborn wrote:
>>> Hi,
>>> I'm trying to setup the provisioning of new OpenStack hypervisors with
>>> cinder volumes on them. The problem is that kickstart doesn't allow
>>> dashed in volume group names?
>>> I tried this:
>>> volgroup cinder-volumes --pesize=4096 pv.02
>>> and this:
>>> volgroup cinder--volumes --pesize=4096 pv.02
>>> but in both cases I end up with a volume group named "cindervolumes" on
>>> the system. Any idea what I have to do to accomplish this?
>>> Defining VGs with dashes works perfectly fine on the command line.
>> Did you try to screen it via "\" ? i.e. "volgroup cinder\-volumes
>> --pesize=4096 pv.02" ?
> Just tried this and the volume group still ends up as "cindervolumes".

Dunno why you're insisting on putting dashes in the name, but have you
tried volgroup 'cinder-volumes', with single quotes around the name?