[CentOS] Need a Centos 6 USB hard drive recovery procedure

Sat May 11 15:23:35 UTC 2013
Fred Roller <fredroller66 at gmail.com>

On 05/09/2013 04:41 PM, Rock wrote:
> My 15GB backup USB drive somehow got "corrupted" such that
> a "chkdsk /f E:" on WinXP removed the file allocation table
> (or whatever) making the NTFS drive appear empty.
> I tried Windows Recuva freeware to recover the files, and
> it has been working for 24 hours; but it has dumped about
> 65,000 files into a separate flat Windows directory.
>   http://www3.picturepush.com/photo/a/12892041/img/12892041.jpg
> Since none of the files were deleted or written over, is
> there a method on Linux that will simply recover the missing
> file allocation directory structure instead of dumping a
> hundred thousand files into a single directory?
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

I had to recover a Red Hat Raid array after a motherboard failure...

This did it:

During the recovery it rebuilt the previous Windows installation as 
well.  It not free but it worked for me several years ago.

Hope it helps.  There are some linux solutions I had at the time and I 
am trying to dig up my notes.