[CentOS] Missing printer driver

Thu May 16 08:22:35 UTC 2013
Ljubomir Ljubojevic <centos at plnet.rs>

On 05/16/2013 08:50 AM, Nicolas Thierry-Mieg wrote:
> Steve Blackwell wrote:
>> On Wed, 15 May 2013 14:26:14 +0200
>> Ljubomir Ljubojevic <centos at plnet.rs> wrote:
>>> On 05/14/2013 03:16 AM, Steve Blackwell wrote:
>>>> I can't remove tcp_wrappers-libs-7.6-57.el6.test.x86_64 because too
>>>> much depends on it.
>>> Give me output of "yum list tcp_wrappers-libs --showduplicates
>>> --disableplugin=*priorities*, I got:
>>> [root at kancelarija etc]# yum list tcp_wrappers-libs --showduplicates
>>> --disableplugin=*priorities*
>>> Loaded plugins: downloadonly, fastestmirror, refresh-packagekit
>>> Determining fastest mirrors
>>> Installed Packages
>>> tcp_wrappers-libs.i686 7.6-57.el6 @plc-os
>>> tcp_wrappers-libs.x86_64 7.6-57.el6 @plc-os
>>> Available Packages
>>> tcp_wrappers-libs.i686 7.6-57.el6 plc-os
>>> tcp_wrappers-libs.x86_64 7.6-57.el6 plc-os
>>> [root at kancelarija etc]#
>>> maybe "yum update" or "yum update tcp_wrappers-libs.i686" will help?
>> # yum list tcp_wrappers-libs --showduplicates --disableplugin=*priorities*
>> Loaded plugins: fastestmirror, refresh-packagekit, security
>> No plugin match for: *priorities*
>> Loading mirror speeds from cached hostfile
>>    * base: mirror.es.its.nyu.edu
>>    * centosplus: centos.netnitco.net
>>    * contrib: mirror.raystedman.net
>>    * epel: mirror.hiwaay.net
>>    * extras: mirror.beyondhosting.net
>>    * remi: remi-mirror.dedipower.com
>>    * rpmforge: mirror.us.leaseweb.net
>>    * rpmforge-extras: mirror.us.leaseweb.net
>>    * updates: mirrors-pa.sioru.com
>> Installed Packages
>> tcp_wrappers-libs.x86_64       7.6-57.el6.test       @rpmforge-testing
>> Available Packages
>> tcp_wrappers-libs.i686         7.6-57.el6            base
>> tcp_wrappers-libs.x86_64       7.6-57.el6            base
>> tcp_wrappers-libs.x86_64       7.6-57.el6.rfx        rpmforge-extras
>> So the problem seems to be the fact that I have the test version from the rpmforge-testing repo installed.
>> I've tried disabling that repo and doing an update but no luck.
>> I've tried doing a yum update of the i686 version but yum says it's available but not installed.
>> Doing a yum install give me the multi-repo error.
>> Is there a way to replace one version with anothe?
> try yum downgrade
First thing to do is to permanently disable rpmforge-testing and 
rpmforge-extras repos with "enabled=0" in /etc/yum.repos.d/rpm...

Next, install priorities plugin: "yum install yum-plugin-priorities -y" 
and add "priorities=<number>" line for each repository in 
/etc/yum.repos.d/ directory, where number will be set to form a hierarchy:

base:             10
centosplus:       10
contrib:          10
epel:             20
extras:           15
remi:             30
rpmforge:         40
rpmforge-extras:  50
updates:          10

But you must be careful to add priorities= line to ANY NEW repository 
you add before you run yum, and give it number larger of 10 to preserve 
the main repositories and stability of your system. Any number >= 10 
will mean that yum can replace main packages with ones from that repository!

Once you setup this, run
"yum downgrade tcp_wrappers-libs"
  to solve your problem,
"yum list installed | grep @rpmforge-testing"
"yum list installed | grep @rpmforge*"
to see any replaced/installed packages from repoforge repository (not a 
good thing to replace packages from main CentOS repos).

List all installed packages from @rpmforge*:

yum list installed | grep @rpmforge* | awk '{print $1}'

Look/compare if installed package was replaced:

yum list <packages> --showduplicates --disableplugin=*priorities*

I can not from top of my help adapt the list from first command to ditch 
everything after the last "." and then remove EOL. Maybe someone can 
solve it and provide a one-liner for you (and the rest of us :) ) to 
compare the list of installed packages with all available packages from 
provided list (first command).

Ljubomir Ljubojevic
(Love is in the Air)
PL Computers
Serbia, Europe

StarOS, Mikrotik and CentOS/RHEL/Linux consultant