[CentOS] SuperMicro with LSI MegaRaid with Centos 6.0

Tue May 21 20:03:51 UTC 2013
m.roth at 5-cent.us <m.roth at 5-cent.us>

Gregory P. Ennis wrote:
> Gregory P. Ennis wrote:
>> I am trying to install a Centos 6.0 system on a SuperMicro with an LSI
>> MegaRaid SCSI 320-2 controller.
>> I had originally tried to install 6.4, but the 6.4 install DVD does not
>> boot with this configuration.
>> See : http://bugs.centos.org/view.php?id=5377
> I don't think you understand how to use it. First, BEFORE YOU TRY TO
> INSTALL, use the firmware option while it's getting up - I think it's
> <ctrl-R>, and create a logical drive, whatever RAID level you want, with
> spares if it's not just RAID 1. Tell it to initialize (you can do a quick
> initialize). Then exit that, and it'll reboot, and Linux will see it
> presented by the controller as one physical drive, and it should be happy.
> Thank you for your response.  You are correct in that I may not
> understand how to configure the LSI, but I had some help that was very
> familiar with the LSI controller, but not familiar with Linux.
> Actually the configuration key is <ctrl-M> or <ctrl-H>, and we did
> create a RAID Level 1; we also did an initialization that resulted in a
> 100% a consistency check.
> After this, I expected to be able to start the 6.0 install, but when the
> install disc got to the point of evaluating the hard discs it did not
> find any, and gave me a prompt screen allowing me to select a driver
> from a list, or add a driver via a floppy disc.  There were (maybe four)
> LSI drivers in their list, and I tried all of them without success.
> Thanks again, any other ideas ??????

If it's any help, some googling suggests that the 320 is what Dell
rebranded as a PERC 4. It's kind of possible that there are 32-bit drivers
for it - it does seem to be an old controller, though.

The firmware for the controller *is* presenting one logical drive, correct?

I also found this:
<http://www.lsi.com/support/Pages/download-search.aspx>, so you might
mouse around and see what you can find. I see it's on that page under
legacy storage, btw.

Good luck.