[CentOS] building software raid.

Sat Nov 2 14:26:47 UTC 2013
Johan Vermeulen <jvermeulen at cawdekempen.be>

Op 01-11-13 17:41, Johan Vermeulen schreef:
> Op 30-10-13 17:38, John Doe schreef:
>> From: Johan Vermeulen <jvermeulen at cawdekempen.be>
>>> no I see I have /dev/md/md_d0 /dev/md_d0p1 /dev/md_d0p2
>>> I don't know what is what....
>> Not sure what you did with lvm but I would say that md_d0 is
>> the (raid) device and md_d0p* are its partitions...
>> Just do fdisk -l /dev/md/md_d0 (or gdisk).
>> JD
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos
> Hello All,
> fdisk -l was what I needed to bring clarity in the name-issue.
> By now I tried this on a just-installed Centos6.4, updated machine, this
> time with partitions instead of lvm.
> I was able to follow the wiki all the way without EM
> /etc/fstab now reads
> //dev/md_d0p3   root
> /dev/md_d0p1  home /
> and so on.
> I adapted /etc/grub.conf to /root=/dev/md_d0p3/ and deleted the rd_NO_MD
> and ran the dracut commands.
> BUT when rebooting I get :
> /dracut warning : No root device "block:/dev/md_d0p" found./
> searching through all the files, I see that /dev/mapper only contains
> control in stead of
> the usual links.
> Could this be the issue?
> And if it is, how can I generate or manualy add the usual links in this
> file?
> Greetings, J.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/cent/*os*/

/Dear All,

I would like to renew my request for help with this wiki:


Still stuck on EM : dracut warning: No root device "block:/dev/md_dop3" 
I think this is a bit of a pain to troubleshoot, because

* to change anything, I have to chroot to /mnt/sysimage every time.
* googling this, I see a a threat marked solved here :

but I can't access it.

So far I tried this :

*  http://lists.centos.org/pipermail/centos/2013-March/133176.html

so i ran  dracut --mdadmconf initramfs.......

but that did change anything

also mentions an almost empty /dev/mapper,
so I am now trying to make a correct symlink in /dev/mapper in order to 
be able to boot the system.

So far I haven't found the right one.

Can anyone shed some light on this?

Many thanks.