[CentOS] 6.4 : How to enable epel and the rpmfusions??

Sat Nov 2 22:24:12 UTC 2013
Mark LaPierre <marklapier at aol.com>

On 11/02/2013 05:25 PM, Beartooth wrote:
> 	I've installed 6.4 on an old T30 ThinkPad, and I'm
> in the midst of setting it up. I can't seem to get an rpm of Pan for it, 
> nor even to do yum update.
> 	Mousing around fedoraproject eventually got me to  http://
> rpmfusion.org/Configuration/ and from there to downloads for the free, 
> nonfree, and epel packages (along with a caveat that tells you -- *after* 
> you've gotten rpmfusion -- to get epel first :-{ ).
> 	The display on the T30 has given trouble recently; while it's 
> working, I tried with packagekit to eliminate the fusions while keeping 
> epel (actually,EPEL; it seems to matter). Packagekit told me that I had 
> to remove the repository configurations along with the fusions -- a thing 
> I'd've done before if I could, whereupon I'd've started over, with EPEL 
> first.
> 	I approved that, then tried to refresh my sources in
> packagekit in order to get the fusions back. This put me through some 
> tedious juggling of non-commutative commands. 
> 	At the end of them, despite a lot of fussing with packagekit and 
> some logging in and out, plus a reboot or two, I was still getting error 
> messages like these for yum install pan *and* yum update : 
> [root at T30 ~]# yum install pan
> Loaded plugins: aliases, changelog, downloadonly, fastestmirror, kabi, 
> presto, refresh-packagekit, security, tmprepo, verify, versionlock
> Loading support for CentOS kernel ABI
> Loading mirror speeds from cached hostfile
> epel/metalink                                            |  14 kB     
> 00:00     
>  * base: mirrors.serveraxis.net
>  * c6-media: 
>  * centosplus: mirror.es.its.nyu.edu
>  * contrib: mirror.raystedman.net
>  * epel: mirror.us.leaseweb.net
>  * extras: mirrors.finalasp.com
>  * rpmfusion-free-updates: mirror.us.leaseweb.net
>  * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
>  * updates: centos.mirrors.tds.net
> file:///media/CentOS/repodata/repomd.xml: [Errno 14] Could not open/read 
> file:///media/CentOS/repodata/repomd.xml
> Trying other mirror.
> file:///media/cdrecorder/repodata/repomd.xml: [Errno 14] Could not open/
> read file:///media/cdrecorder/repodata/repomd.xml
> Trying other mirror.
> file:///media/cdrom/repodata/repomd.xml: [Errno 14] Could not open/read 
> file:///media/cdrom/repodata/repomd.xml
> Trying other mirror.
> Error: Cannot retrieve repository metadata (repomd.xml) for repository: 
> c6-media. Please verify its path and try again
> [root at T30 ~]# 
> 	I should probably mention that, when I launch packagekit, go to 
> System and then to Software Sources, everything from CentOS-6-Base to 
> CentOS-6-Updates is already checked *except* the one for media. 
> 	Trying to fix that has been an exercise in futility -- I haven't 
> found a way to tell it anything to use as c6-media. (It won't accept an x 
> in the apposite box.) As root, I got to ///media on another machine as 
> well as on the T30, and both are empty. (The other machine won't install 
> Pan either; but it does do yum update.)
> 	Clue, please? Pretty please??

In /etc/yum.repos.d/CentOS-Media.repo change the enabled line to:


   ^ ^  Mark LaPierre
Registered Linux user No #267004