[CentOS] restarting network interface

Thu Nov 21 03:40:33 UTC 2013
Clint Dilks <clint.dilks at gmail.com>


The most likely answer is that your interface is not enabled.

Try someting like

cat /etc/sysconfig/network-scripts/ifcfg-em1

You will see for a disabled interface ONBOOT="no"

Change the no to a yes and you should be good :)

On Thu, Nov 21, 2013 at 4:32 PM, Wes James <comptekki at gmail.com> wrote:

> I googled to see how I might restart the network interface in CentOS.  I
> initially tried before googling:
> sudo service network restart
> I noticed that only the loopback interface was restarted.  To confirm this
> I did:
> service network stop
> and then did
> ifconfig
> and the loopback info was gone.  I then found ifconfig eth0 up/down and
> tried those and that did what I is was looking for.  Why doesn't "service
> network restart" restart all interfaces?
> Thanks,
> -wes
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos