[CentOS] X11 connection rejected because of wrong authentication

Tue Nov 26 01:34:13 UTC 2013
Timothy Murphy <gayleard at eircom.net>

James Hogarth wrote:

>> >> I'd like to run SELinux on my CentOS server in enforcing mode,
>> >> but I get the above message when I run sealert.
>> >> I assume this is because I am accessing the server from my laptop?
>> ..
>> >> Am I right in thinking the message arises from my remote connection?
>> >> And if so, is there a simple solution?
>> > Too little information at present to tell.
>> >
>> > Does it work if the system is in permissive?
>> The CentOS server is running with SELinux in permissive mode.
>> I would prefer to run it in enforcing mode,
>> and to that end would like to solve the problem above.

> Just to be clear - does it work (X forwarding) as it is now with the
> system in permissive mode ... Does it only fail after you go setenforce 1
> ?

The system works perfectly (with X forwarding) in permissive mode.
I haven't tried it in enforcing mode, as it is a remote server
and it would be inconvenient if I could not communicate with it.

It has been suggested to me that the problem has nothing to do with selinux.
The reason I thought there was a connection is that the warning only appears
in the output of sealert.

Timothy Murphy  
e-mail: gayleard /at/ eircom.net
School of Mathematics, Trinity College, Dublin 2, Ireland