[CentOS] mdraid Q on c6...

Mon Jun 23 18:10:03 UTC 2014
SilverTip257 <silvertip257 at gmail.com>

On Sun, Jun 22, 2014 at 4:15 AM, John R Pierce <pierce at hogranch.com> wrote:

> so, I installed a c6 system offsite today, had to do it in a hurry.
> box has 2 disks meant to be mirrored...  I couldn't figure out how to
> get anaconda to build a LVM root on a mirror, so I ended up just
> installing a /boot and vg_system on sda and raid it later.

The installer's graphical mode (as opposed to how it worked in EL5 with
text mode) is the only interactive way to edit partitioning on EL6.

In your kickstart file,
 - specify the partitioning
 - specify "graphical" keyword to boot to the graphical installer

> every howto I find for linux says to half-raid the OTHER disk, COPY
> everything to it, then boot from it and wipe the first disk and then
> bond it as a mirror of the 2nd.   Thats kind of ugly.

Makes sense to me.
There's metadata written to the mdadm underlying devices.


> in solaris, you can tell it that your existing partition is half of a
> mirror, update /etc/vfstab, then reboot, and then join a mirror to it.
> this seems much cleaner to me than copying everything.

What does Solaris magically do that allows this to be supported work?
( I'm not familiar with Solaris so I'd be curious to know. )

> I tried to do this the solaris way, and at the first step, am told...
>     # mdadm --create /dev/md0 --level=mirror --raid-devices=2 /dev/sda2
>     missing
>     mdadm: cannot open /dev/sda2: Device or resource busy
> /dev/sda2 contains the LVM root vg...
> so... I'm thinking I''ll boot a rescue system from usb, create the half
> mirror, then reboot to the incomplete raid and add mirror /dev/sdb2
> will the VG be found on /dev/md0 instead of on /dev/sda2 ?

if so, is there any other reason this won't work?

I believe if you do find  away to get it to work, you'll have major
problems with the partition and not the raid getting mounted.

And to comments about RAID10, it is not possible to add disks to a RAID10
array.  Although I've not done it (my RAID10s are in hardware) I'd expect
you could specify missing disk members.

//  SilverTip257  //