[CentOS] sshd_config AllowUsers syntax wrong in documentation

Thu Jun 26 14:31:02 UTC 2014
Kai Schaetzl <maillists at conactive.com>

Reindl Harald wrote on Thu, 26 Jun 2014 13:04:21 +0200:

> not true

Don't say it's "not true". ;-) I tried it at least half an hour with all 
possible combinations and only the user@* pattern worked. I made 
absolutely sure that I restarted the ssh server each time. I know also 
pretty well, that I had the same problem at least once some time ago, but 
didn't investigate then. As soon as I add a second user and restart the 
server I get the error I mentioned earlier.

I've re-checked now after changing some of the config to yours and it 
works without the host part. I removed the changes and it is still 
working. I'm a bit puzzled. If I hadn't been sure before I wouldn't have 

The only settings that were different from yours were:
> GSSAPIAuthentication no
> GSSAPICleanupCredentials no
> X11Forwarding no
> PermitRootLogin
just PermitRootLogin yes

but, as said, no change there, back and fro, makes a difference, it works 
with your and with mine settings.

> AllowGroups root sftp-users apache
not set at all
> DenyUsers apache wwwcron
not set at all

So, whatever, it works now as it should. Thanks, anyway.