[CentOS] Custom respin ISO prompting for discs

Tue Jun 3 15:21:05 UTC 2014
Karl MacMillan <karlwmacmillan at gmail.com>

I'm creating a custom install / respin ISO with updated packages and a
kickstart - starting from CentOS 6.5 minimal install DVD. I'm generally
following the directions from

I can create the iso, boot, have it find the installation media (it prints
"Found local installation media"), partition the disks, resolve the
dependencies, and then when it gets to "Starting installation" it prompts
with "Please insert CentOS disc 1 to continue".

Debugging I've done so far (all but 4 result in the prompt for disc 1):

1. I've verified that the package set I have resolves all dependencies by
testing the installation into a new rpmdb.
2. I've copied over the minimal install DVD contents directly, placed
comps.xml in the Packages directory, and recreated repodata (using
'createrepo -g Packages/comps.xml -o . Packages/").
3. Built on both CentOS 6.5 (with all updates) and Fedora 20.
4. Also tried to minimal DVD _without_ running createrepo (just placed the
kickstart in the root of the image). This worked fine.

That 4 works suggest that createrepo is at fault, but I can't for the life
of me figure out what is going on. I've done this without a base url (-u)
and with (using 'head -1 .discinfo).

Can anyone offer some suggestions for how to debug further?

Thanks - Karl