[CentOS] quota doesn't appear to work - repquota only updates when quotacheck is run

Tue Sep 16 09:36:36 UTC 2014
Alexander Rusa <alexander.rusa at emerion.com>

I have exactly the same problem that you experienced in Nov, 2013.
I am using ext4 with journaled quota and the quota usage is only updating when I run quotacheck manually.
Have you found a solution?

> I have set up user quotas on an ext4 filesystem.  It does not appear that
> the quota system is being updated, except when I manually run quotacheck.
> More detail: I run "warnquota -s" from a script in /etc/cron.daily.  I
> noticed that no one had received an "over quota" message in a long time.
>  Using "repquota -as", it indeed looked as though everyone was under their
> quotas.  But "du" showed many people were over quota.  So I did a "quotaoff
> -a ; quotacheck -vam ; quotaon -a".  That night, several
> warnquota-generated messages went out.  My users diligently cleaned up
> their homes.  Fast forward 24 hours, and the users received the same
> warnquota emails.  repquota showed them as being over, but "du" told a
> different story.
> System is CentOS 6.3, kernel 2.6.32-279.2.1.el6.x86_64.
> # dmesg | grep -i quota
> VFS: Disk quotas dquot_6.5.2
> The partition is type ext4 mounted at /share:
> # cat /proc/mounts | grep share
> /dev/mapper/VolGroup_Share-LogVol_Share /share ext4
> rw,noatime,nodiratime,barrier=0,nobh,data=writeback,jqfmt=vfsv0,usrjquota=aquota.user
> 0 0
> The ext4 volume sits on top of an lvm logical partion.  That logical volume
> ultimately sits on top of an encrypted disk using cryptsetup luksFormat:
> # lvscan
>   ACTIVE            '/dev/VolGroup_Share/LogVol_Share' [4.48 TiB] inherit
> # pvscan
>   PV /dev/mapper/luks-7f865362-ee9f-40de-bc07-73701b4662f3   VG
> VolGroup_Share   lvm2 [4.48 TiB / 0    free]
> Is there something in my ext4 mount options that is incompatible with
> quota?  Or maybe the encrypted layer is causing problems?  Am I missing
> something else?
> Thanks!