[CentOS] Calibre installation fails on C7

Wed Dec 23 16:26:29 UTC 2015
Wes James <comptekki at me.com>

> On Dec 22, 2015, at 9:13 PM, Fred Smith <fredex at fcshome.stoneham.ma.us> wrote:
> On Tue, Dec 22, 2015 at 09:03:28PM -0700, Wes James wrote:
>>> On Dec 22, 2015, at 8:06 PM, Fred Smith <fredex at fcshome.stoneham.ma.us> wrote:
>>> Attempting to install latest Calibre on Centos-7, getting:
>> typed in "calibre ssl install error” to google
>> first hit:
>> http://stackoverflow.com/questions/26615914/calibre-fails-to-install <http://stackoverflow.com/questions/26615914/calibre-fails-to-install>
>> not sure if it helps (the no check cert option??)
> Nope. makes no difference.

I tried making sure all the packages were installed on the bottom of the page:

http://calibre-ebook.com/download_linux <http://calibre-ebook.com/download_linux>

but then qmake wasn’t available, so I found I needed qt3 installed.  Installed that and tried installing again:

python setup.py install
Traceback (most recent call last):
  File "setup.py", line 13, in <module>
    import setup.commands as commands
  File "/home/xulu/Downloads/calibre/calibre-2.47.0/setup/commands.py", line 28, in <module>
    from setup.translations import POT, GetTranslations, Translations, ISO639, ISO3166
  File "/home/xulu/Downloads/calibre/calibre-2.47.0/setup/translations.py", line 14, in <module>
    from setup.parallel_build import parallel_check_output
  File "/home/xulu/Downloads/calibre/calibre-2.47.0/setup/parallel_build.py", line 14, in <module>
    from setup.build_environment import cpu_count
  File "/home/xulu/Downloads/calibre/calibre-2.47.0/setup/build_environment.py", line 98, in <module>
    from PyQt5.QtCore import PYQT_CONFIGURATION
ImportError: No module named PyQt5.QtCore

Hmm.  So I tried:

sudo pip install python-qt5
Collecting python-qt5
  Using cached python-qt5-0.1.10.zip
No files/directories in /tmp/pip-build-5OToGt/python-qt5/pip-egg-info (from PKG-INFO)

and get the error above.  So I’m stuck there.  But I don’t see a /tmp/pip-build…. either??