[CentOS] Yum Weird Message

Mon Dec 28 22:16:07 UTC 2015
Alice Wonder <alice at domblogger.net>

On 12/28/2015 02:10 PM, Marcelo Roccasalva wrote:
> On Mon, Dec 28, 2015 at 5:24 PM, Alice Wonder <alice at domblogger.net> wrote:
>> I ran into this exact issue last night -
>> http://www.iotti.biz/?p=433
>> When a computer is connected via IPv4 but the IPv4 a repo host connects to is not available, yum then tries the IPv6 address and will fail with a confusing message telling you it failed to connect to the IPv6 address.
>> I don't know if there is a way for yum to figure out whether the current network connection to the Internet is IPv4 or IPv6.
>> But if there is a way, it might make a usability improvement. A lot of people have no idea what IPv6 is and would be confused.
>> I was confused myself at first, wondering if DHCP pulled in IPv6 from the router.
> If your DNS answers IPv6, it will have prefence over IPv4. You can set
>   ip_resolve=4 in your yum.conf

The issue is the yum server was down, so IPv4 didn't work.

Once that server was back up (third party repo) it of course worked no 

The issue is the error message, while a technically correct one, is one 
that is not very user friendly and can be confusing to people who are 
not dual-stack.

It could be improved.

Sent my from my laptop, may not be able to respond timely