[CentOS] how to delete a trashed kernel

Thu Jan 1 22:49:38 UTC 2015
Don Vogt <dnvot at yahoo.com>

I have a screwed up disk arrangement, but I have had no trouble because of it after using it over a year. Recently I did a yum update. After starting the update, which included a new kernel, it seemed to either freeze or loop. It was a long time at the  prompt and I got impatient and did a Ctrl C. I then tried to re-boot. The result was a kernel panic. I am keeping 5 kernels and when I select  the second kernel it boots OK. Now I would like to remove the bad kernel. One other thing that I don't understand and may be relevant, the name of the bad package is        kernel-2.6.32-504.3.3.el6.centos-plus.i386
 I have never noticed a "centos-plus" in a kernel name before. Does the centos-plus repo deal out kernels?I have tried yum remove and "gpk application" (add and remove software) with no luck.I have tried google, but all the solutions for kernel deletions were to delete old kernels. I don't want to do that because I would be deleting my backups. I am in no hurry because I can still boot and it is possible that if I can wait through several kernel updates yum might delete the bad one after an update. I should have mentioned that I am using grub2 to boot, although I don't think that has anything to do with deleting the kernel package.I would appreciate any advice (except "go back to windows")