[CentOS] Radeon graphics problems with CentOS 6.6

Wed Jan 7 14:02:22 UTC 2015
Darby Vicker <darby.vicker at gmail.com>

I sent this last night but it didn't show up in the archives.  Trying
again without the attachment.  Are messages with attachments blocked
on this list?

On Tue, Jan 6, 2015 at 11:50 PM, Darby Vicker <darby.vicker at gmail.com> wrote:
> Thanks a ton for the suggestions and info everyone.
>> Two things I think you should consider doing...
>> 1) in your next post (and any bugs you open), include the `uname -a` of
>> the last known to work correctly CentOS/RHEL kernel, and the `uname -a`
>> of the first known to not work correctly CentOS/RHEL kernel and the
>> respective versions of radeon &| flrgx drivers.
> Sure.
> Last known kernel to work (pretty sure this is the last update under
> CentOS 6.5):
> Linux c6 2.6.32-431.29.2.el6.x86_64 #1 SMP Tue Sep 9 21:36:05 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
> Kernels I've tried that don't work:
> kernel-2.6.32-504.el6.x86_64
> kernel-2.6.32-504.1.3.el6.x86_64
> kernel-2.6.32-504.3.3.el6.x86_64
> kernel-2.6.32-504.3.3.el6.centos.plus.x86_64
> Graphics card:
> 00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6530D]
> Open source driver version:
> xorg-x11-drv-ati-7.3.99-2.el6.x86_64
> I tried the proprietary drivers from elrepo too:
> fglrx-x11-drv-14.9-1.el6.elrepo.x86_64
> But it crashes X and also renders the system unreachable via ssh.  When
> X crashes with the open source driver, I can still get in via ssh.  I
> can boot to an older kernel with the fglrx drivers but graphics
> performance is awful for some reason.
>> 2) try out elrepo's el6 kernel-lt & kernel-ml and see if they work
>> correctly for you.  I suggest this, because for me it did workaround an
>> issue with intel chips (I guess I need to see what it will take to get
>> the elrepo folks to make just a back-ported intel driver from 3.17
>> [first known to work again, 3.16 does not]) .
>> http://lists.centos.org/pipermail/centos/2014-November/147579.html
> Great suggestion.  I just installed and booted the following kernel-ml.
> Linux c6 3.18.1-1.el6.elrepo.x86_64 #1 SMP Tue Dec 16 20:44:33 EST 2014 x86_64 x86_64 x86_64 GNU/Linux
> And it works!  I got A LOT of bad-looking errors on boot but it did
> boot and everything seems to work fine.  I've attached the boot.log
> just FYI.  I have not tried kernel-lt but I suspect it will work fine
> since it would install a 3.10 kernel.  (Based on the bugs below this
> problem doesn't appear in the 3.X branch until about 3.16).
> After searching the RHEL bug tracker, I do see some very similar bugs
> to what I'm experiencing.
> https://bugzilla.redhat.com/show_bug.cgi?id=1161321
> https://bugzilla.redhat.com/show_bug.cgi?id=1151757
> Both are on 3.X kernels under Fedora so not completely applicable.  The
> first one even has the same graphics card as I do - no activity
> though.  The second one is also very similar.and in one of the comments
> it was suggested to do this:
>> 2) If not, it looks like everyone else is using an ATI Radeon card and
>> likely something broke between 3.15 and 3.16. Please boot with "nomodeset" as
>> a grub option and report back. If it boots correctly, try modprobing radeon and
>> see if the screen goes black right away
> This sounded worthwhile so I booted successfully on the
> 2.6.32-504.3.3.el6.x86_64 kernel with "nomodeset".  I tried this before
> (as described in my xorg thread) and I get a lot of artifacts in the
> graphics but it does work.  However, the radeon driver is already
> loaded after I boot.  This is directly after the boot:
> [root at c6 ~]# lsmod | grep rad
> radeon               1536476  0
> ttm                    81172  1 radeon
> drm_kms_helper         82994  1 radeon
> drm                   291284  3 radeon,ttm,drm_kms_helper
> i2c_algo_bit            5711  1 radeon
> i2c_core               29964  12 tda18271,s5h1411,cx25840,cx23885,v4l2_common,videodev,tveeprom,i2c_piix4,radeon,drm_kms_helper,drm,i2c_algo_bit
> [root at c6 ~]#
>>> http://bugs.centos.org/view.php?id=4586
>> Actually, I ask that people open a new ticket for each request. :)
>> Akemi
> Akemi, maybe its not clear yet but would you prefer I submit this bug
> under the CentOS or RHEL tracker?  (And do you know if I can submit to
> the RHEL tracker without a RHEL subscription?)  Any advice on where to
> submit this info to get this fixed in the CentOS 6 line would be
> appreciated.