[CentOS] could not insert 'fuse' error on CentOS 7.1

Sun Jun 7 02:27:48 UTC 2015
Tim Dunphy <bluethundr at gmail.com>

Hey guys,

 I tried installing the latest fuse on CentOS 7.1. I downloaded the latest
version (2.9.4) from sourceforge and did a source install. After rebooting
the host, now when I go modprobe fuse, this is what I get!

*modprobe: ERROR: could not insert 'fuse': Unknown symbol in module, or
unknown parameter (see dmesg)*

If I tail dmseg this is all I see, but it doesn't seem relevant:

[root at ops:~] #dmesg | tail
[    3.342679] input: PC Speaker as /devices/platform/pcspkr/input/input4
[    3.351981] piix4_smbus 0000:00:01.3: SMBus base address uninitialized -
upgrade BIOS or use force_addr=0xaddr
[    3.502014] ppdev: user-space parallel port driver
[    3.539306] AES CTR mode by8 optimization enabled
[    3.590103] alg: No test for __gcm-aes-aesni (__driver-gcm-aes-aesni)
[    3.635925] alg: No test for crc32 (crc32-pclmul)
[    3.659506] type=1305 audit(1433643281.958:4): audit_pid=472 old=0
auid=4294967295 ses=4294967295 subj=system_u:system_r:auditd_t:s0 res=1
[    4.084861] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    9.575888] systemd-journald[393]: Received request to flush runtime
journal from PID 1
[   10.702056] Adjusting xen more than 11% (9436999 vs 9311354)

Has anyone out there encountered this error with fuse and been able to
overcome it?

I've tried googling this to no avail!!


GPG me!!

gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B