[CentOS] creating RPMs from CRAN tarballs

Wed Jun 3 20:01:29 UTC 2015
Tony Schreiner <anthony.schreiner at bc.edu>

If I may add

The created spec file does not list the dependency on /usr/bin/r, something
in rpmbuild creates it.

On Wed, Jun 3, 2015 at 3:49 PM, Tony Schreiner <anthony.schreiner at bc.edu>

> This is not specifically a CentOS question, but I  am creating RPMS for
> CentOS 6 from some CRAN tarballs.
> I run R2spec -s tarball  to create a spec file, and most of the time it
> works ok, but sometimes (RPostgresSQL, Rcpp for example) the package has
> test or example programs that  start with
> #!/usr/bin/r
> with lower case r, and the resulting package then winds up with a
> dependency on /usr/bin/r, which can't be resolved.
> So far I have solved it by editing all the files and replacing with
> /usr/bin/R, recreating the tarball and going through the process again, but
> I have to believe there is an easier way.
> Is there a option to not create the dependency?
> Thanks
> Tony Schreiner