[CentOS] newbie question on installation over existing Linux

Wed Jun 10 21:49:49 UTC 2015
Warren Young <wyml at etr-usa.com>

On Jun 10, 2015, at 12:49 PM, Patrick Hess <patrickhess at gmx.net> wrote:
> Warren Young wrote:
>> /usr was already assumed to be on the root FS in Solaris, FreeBSD
> I'm using both Solaris and FreeBSD quite extensively and, honestly,
> have never heard of that assumption.

I don’t have a “real” Solaris installation here to try, but the OpenIndiana, DilOS and SmartOS forks of OpenSolaris all symlink /bin to /usr/bin.  I expect the same is true of Solaris 11, though I wouldn’t be surprised to learn that Solaris 10 still kept /usr separate, given its 2005 release date.

As for FreeBSD, I’m basing that on the fact that the last time I tried moving /usr to a ZFS volume, back in the days when it could only boot to UFS, the system couldn’t even boot into single user mode.  I had to reinstall the OS to fix that box.

I suspect if I tried UFS-root + ZFS-/usr again today, on a 10.1 box, it would succeed as a side effect of the root-on-ZFS support, but only because it would allow /usr to come up early enough to allow the boot to proceed.  I suspect if you nuked /usr, it again would fail to boot.

The bottom line is that we now live in a world where even the piggiest OSes will install with room to spare on a throwaway removable flash drive.  The rationale behind /usr-free single-user boots is defunct.