[CentOS] CentOS 7 + Dell Latitude E6420 laptop = thermalshutdown

Wed Jun 17 02:49:23 UTC 2015
deoren <centos-list at whyaskwhy.org>

On 6/16/2015 8:40 PM, Jason Pyeron wrote:
>> -----Original Message-----
>> From: deoren
>> Sent: Tuesday, June 16, 2015 9:26 PM
>> Looks like the system is a bit warm, but not overly so? So 
>> far I've not figured out how to check the fan speed. I'll 
>> keep looking.
> That is the tell tail sign, as it is not cool when under low to no load.
> Force the fan to high (dell diagnostic CD or other program) should be strong
> (moves an empty paper coffee cup) cold air blowing.
> -Jason 

Good tip, thanks.

I tried using the onboard Dell diagnostics and it shows that the current
Processor Fan speed is about 2906 RPMs. It _did_ click loudly once and
then appeared to pick back up. Attempts to run the test aren't yielding
any high spin up/down noises like I'm used to hearing from other systems.

Current thermal readings (inside of the diagnostics screen):

CPU Thermistor: 65C
Ambient Thermistor: 27 C
SODIMM Thermistor: 39 C
Video Thermistor: 54 C

Back on the topic of the diagnostics, I'm running a CPU stress test and
the CPU Thermistor has grown to 69 C.

After some time the fan speed has finally increased to 3257 RPM and I
can finally clearly hear that it is spinning. Once the test completed
and the CPU temp started dropping, so did the fan speed, finally
settling back to about 2900 RPM.

I'm still puzzled why the laptop appears to lockup when attempting to
login to the desktop environment when using CentOS, but not Ubuntu
15.04. Any thoughts there?

Back on the topic of CentOS, I ran 'watch /usr/bin/sensors' for about 20
minutes and the temp only slightly fluctuated. It was only the login
attempt that shut down the system.