[CentOS] gssproxy items...

Tue Jun 30 20:28:29 UTC 2015
Erik Laxdal <elaxdal at ece.uvic.ca>

On 06/30/2015 12:13 PM, m.roth at 5-cent.us wrote:
> Erik Laxdal wrote:
>> The problem I am encountering with Kerberized NFSv4 is that the
>> directory will mount okay, and I can see it's contents as root, but I
>> encounter "Permission denied" errors when trying to access it as a
>> regular user.  'klist -ce' returns valid results as the user (including
>> a a line for the server spn that I was trying to access), and I am able
>> to access Kerberized NFSv4 shares hosted on EL6 servers as the same user.
> <snip>
> Stupid question: selinux?
Not a stupid question, selinux has gotten me with other things from time
to time.  The server was setup with selinux set to enforcing by default,
but I have tried 'setenforce 0', changing it to permissive, and finally
disabled (rebooting after each of these state changes) with no change in

On the client side, I've only tried the 'setenforce 0' command.  The
gssproxy-0.4.1-1 package was only installed on the server and worked
with selinux enabled on both the server and client sides.  The client
side also has no problem accessing Kerberized NFSv4 shares from EL6
systems with selinux enabled on it.