[CentOS] yum errors

Fri Nov 20 17:58:32 UTC 2015
Wes James <comptekki at me.com>

> On Nov 20, 2015, at 10:41 AM, Jim Perrin <jperrin at centos.org> wrote:
> It should be looking at /6/ instead of a specific point release. We
> (CentOS) do not provide updates for individual point releases. You are
> several years behind in security and bug-fix updates. Once a specific
> minor version is expired, it is moved off the main mirrors and into the
> vault. The current iteration of the /6/ tree is 6.7, so everything below
> that is no longer available on the mirrors. Have you modified your
> repository files or are they stock?
> I might suggest starting off with a 'yum clean all', then running your
> query again.
> On 11/20/2015 11:21 AM, Wes James wrote:
>> I have inherited centos 6.3 and 6.2 vms in an esxi environment.  When I do
>> yum provides ntpd
>> on the 6.3 box I get a lot of errors like:
>> Loaded plugins: fastestmirror, presto
>> Loading mirror speeds from cached hostfile
>> * base: mirror.unl.edu
>> * extras: mirrors.cmich.edu
>> * updates: mirror.steadfast.net
>> http://mirror.unl.edu/centos/6.4/os/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 -

This is what happened:

yum clean all
Loaded plugins: fastestmirror, presto
Cleaning repos: base extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors
8 delta-package files removed, by presto

yum provides ntpd
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os error was
12: Timeout on http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os: (28, 'connect() timed out!')
Error: Cannot find a valid baseurl for repo: base

What next?

Actually, I think I have a firewall issue.  I googled the error and someone suggest trying:

curl 'http://mirrorlist.centos.org/?release=6&arch=i386&repo=os' <http://mirrorlist.centos.org/?release=6&arch=i386&repo=os'>

So I tried that on my 6.4 virtualbox and it worked.  I tried it on the esxi vm and it timed out.