[CentOS] Kickstarting CentOS 7 VM on CentOS 6 not possible?

Mon Nov 23 21:40:54 UTC 2015
Fabian Arrotin <arrfab at centos.org>

Hash: SHA1

On 23/11/15 09:59, Jos Vos wrote:
> Hi,
> On CentOS 6.7 (all updates) kickstarting a CentOS 7 VM (in the way
> it always has worked for other versions, incl. Fedora 22 VM's),
> does not work for me.  I use virt-install with a local copy of the 
> "images/pxeboot" tree.  It all stops with:
> ... [  OK  ] Reached target Paths. [  OK  ] Reached target Basic
> System. dracut-initqueue[551]: Warning: Could not boot. 
> dracut-initqueue[551]: Warning: /dev/root does not exist Starting
> Dracut Emergency Shell... Warning: /dev/root does not exist ...
> I found zillion references to similar problems, including
> PXE-related (I do not use PXE, but "-l" with virt-install) and
> cobbler-related (no Cobbler involved), and I tried some of the
> suggestions, but none of them worked.
> Installing CentOS 7 "manually" using virt-install and the netboot
> ISO works fine, but I want to use kickstart files.
> Thanks for any suggestion.

I can say that it works for sure, so can you share your virt-install
command / kickstart / extra-args ?

I'm injecting the kickstart directly into the initrd.img
(transparently through --initrd-inject= )

- -- 
Fabian Arrotin
The CentOS Project | http://www.centos.org
gpg key: 56BEC54E | twitter: @arrfab
Version: GnuPG v2.0.22 (GNU/Linux)