[CentOS] firewalld being stupid

Fri Nov 6 21:31:09 UTC 2015
Nick Bright <nick.bright at valnet.net>


One of my biggest frustrations with CentOS 7 has been firewalld.

Essentially all of the documentation just flat doesn't work.

One common thing that needs to be done is to change the zone of an 
interface, however I've tried:

firewall-cmd --permanent --zone=internal --change-interface=ens192
firewall-cmd --permanent --zone=internal --add-interface=ens192

I've also tried setting in /etc/sysconfig/network-scripts/ifcfg-ens192:


No matter what, when firewalld starts, ens192 will be in the public zone.

What am I doing wrong? Why does the documented command structure not work?

-  Nick Bright                                -
-  Vice President of Technology               -
-  Valnet -=- We Connect You -=-              -
-  Tel 888-332-1616 x 315 / Fax 620-331-0789  -
-  Web http://www.valnet.net/                 -
- Are your files safe?                        -
- Valnet Vault - Secure Cloud Backup          -
- More information & 30 day free trial at     -
- http://www.valnet.net/services/valnet-vault -

This email message and any attachments are intended solely for the use of the addressees hereof. This message and any attachments may contain information that is confidential, privileged and exempt from disclosure under applicable law. If you are not the intended recipient of this message, you are prohibited from reading, disclosing, reproducing, distributing, disseminating or otherwise using this transmission. If you have received this message in error, please promptly notify the sender by reply E-mail and immediately delete this message from your system.