[CentOS] FCGIWrapper

Tue Nov 17 02:24:27 UTC 2015
Jonathan Billings <billings at negate.org>

On Tue, Nov 17, 2015 at 06:33:35AM +0800, Siva Prasad Nath wrote:
> Hi,
> I am setting up my development environment. I am new to linux.
> I installed Apache on CentOS 7.0. I modified /etc/httpd/conf/httpd.conf and
> tried to restart Apache.
> I got the below error'
> AH00526: Syntax error on line 393 of /etc/httpd/conf/httpd.conf
> Wrapper /home/currencybooking/fcgi-bin/php5.fcgi cannot be accessed:...enied
> The line no 393 in  /etc/httpd/conf/httpd.conf is
> FCGIWrapper /home/currencybooking/fcgi-bin/php5.fcgi .php

SELinux is going to not let you run executable content out of
/home/currencybooking/.  I suggest putting it in /var/www/cgi-bin/.

> Later I tried to install FCGIWrapper.
> [root at cbcdev mod_fastcgi-2.4.6]# make top_dir=/usr/lib64/httpd
> Makefile:12: /usr/lib64/httpd/build/special.mk: No such file or directory
> make: *** No rule to make target `/usr/lib64/httpd/build/special.mk'.  Stop.
> I am not to able to build the package.

Why are building it yourself?  mod_fcgi is in EPEL.

Most likely you need to install the httpd-devel package if you're
going to be building your own software aganst Apache httpd.

> Do I need to change the ownership if I copied file from production to Dev?

What was the development platform?

Jonathan Billings <billings at negate.org>